Page 1 of 1

Yet another '90s fan

Posted: Thu Apr 25, 2019 3:04 pm
by String_Relativity
Great to see a community still dedicated to UA! Completely love this game!

Dug this out of the 'basement' so to speak and have got it working on Windows 10, however when looking for the MetropolisDawn expansion, i hit an error.

The redirect link called "downloads" on the board index comes up with the following message:

Code: Select all

Your connection is not private
Attackers might be trying to steal your information from files.metropolisdawn.com (for example, passwords, messages, or credit cards). Learn more
NET::ERR_CERT_DATE_INVALID
 
Help improve Safe Browsing by sending some system information and page content to Google. Privacy policy
Edit: Chrome and Internet Explorer won't let me go past this point.

In a nutshell, i would love to download a compiled UA source.exe? as well as the MetropolisDawn expansion and hope this is a temporary error!

Thanks heaps for taking the time to read this,
String.

Re: Yet another '90s fan

Posted: Sat Apr 27, 2019 6:51 am
by Ormu
Welcome.

I think the downloads section went offline after this forum was moved to Amazon services but it will be back online when GoldStar611 gets the new systems running.

UA Source can be downloaded via the links in the first post of the UA Source thread.

Re: Yet another '90s fan

Posted: Sat Apr 27, 2019 12:20 pm
by String_Relativity
Thanks!
I have the Source from Github, just still trying to figure out how to get it into a working .exe on windows 10!

Been years since i did any kind of computer work!

Edit: Its working now and its quite nice!
Text does not display on the menus or ingame (only numbers display)
Double checked i had the fonts in the right place, still working on finding the problem.

Re: Yet another '90s fan

Posted: Tue Apr 30, 2019 8:25 am
by CharlotteLabyrinth
Hello String_Relativity, welcome to Stoudson Corporation!
(I really like your username & signature!)

The Downloads section initially worked without problems just after our migration, but accessing the page now gives me the error code ('DLG_FLAGS_SEC_CERT_DATE_INVALID') as well. Apparently it seems like an outdated SSL certificate issue…

A compiled UA_Source.exe can be downloaded from the link at the first page of UA:Source thread, as pointed out by Ormu. Unless you really wish to compile an .exe on your own, it is recommended to use it.

EDIT: It seems like you've already got it working! Regarding the missing texts problem, it might be caused by corrupted font files and/or missing 'language.lng' file used by UA:Source.

Re: Yet another '90s fan

Posted: Tue May 07, 2019 4:18 pm
by String_Relativity
Thanks CharlotteLabyrinth !

I actually failed at compiling.
Started off with Cygwin64, which i chose as my replacement for CMD.EXE.
I could get it to navigate into the right directory, but when i tried to compile all the files inside \src it would not recognize my command or gave me some error.

Nearly makes me want to install Linux after looking at how short the instructions were to compile on that system!

As for the text problem that was solved by doing a full re-install of my Urban Assault.

Sorry for the delayed reply, soon as i got it working, its been my main focus when i get home hahaha.

Such a great game, no others i know of even come close to a good RTS+FPS.
Though Sulgor really need some pesticide.....